海运的博客

潘多拉/OpenWRT配置无线wifi访客网络

发布时间:March 18, 2019 // 分类:K2P // No Comments

配置一个无线接口,device名称见同配置文件:

config wifi-iface 'guest'
        option device 'ra'
        option mode 'ap'
        option ssid 'PandoraBox-2.4G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

给创建的无线接口配置静态IP:

config interface 'guest'
       option proto 'static'
       option ipaddr '10.0.0.1'
       option netmask '255.255.255.0'

配置dhcp:

config dnsmasq
        #监听所有网卡
        option nonwildcard '0'
        #监听特定网卡
        #option nonwildcard '1'
        #list interface 'lan'    
        #list interface 'guest'  
        #略过

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '1h'

配置iptables防火墙,访客网络接口为ra1:

iptables -A INPUT -i ra1 -p udp -m multiport --dport 53,67:68 -j ACCEPT
iptables -A FORWARD -i ra1 -o pppoe-wan -j ACCEPT

同时开放5G和2.4G访客网络:

config wifi-iface 'guest'
        option device 'ra'
        option mode 'ap'
        option ssid 'PandoraBox-2.4G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

config wifi-iface 'guest5'
        option device 'rax'
        option mode 'ap'
        option ssid 'PandoraBox-5G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

将2.4G和5G桥接:

config interface 'guest'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'ra1 rax1'
        option _orig_bridge 'true'
        option ifname 'rax1'
iptables -A INPUT -i br-guest -p udp -m multiport --dport 53,67:68 -j ACCEPT
iptables -A FORWARD -i br-guest -o pppoe-wan -j ACCEPT

更改guest无线密码:

#!/bin/sh
str=haiyun`date +%s|cut -c 7-10|sed 's/4/6/g'`
echo $str
uci set wireless.guest.key=$str
uci set wireless.guest5.key=$str
uci commit wireless
wifi reload

参考:
https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guest-wlan

标签:none

评论已关闭

分类
最新文章
最近回复
  • 海运: 地址格式和udpxy一样,udpxy和msd_lite能用这个就能用。
  • 1: 怎么用 编译后的程序在家里路由器内任意一台设备上运行就可以吗?比如笔记本电脑 m参数是笔记本的...
  • 孤狼: ups_status_set: seems that UPS [BK650M2-CH] is ...
  • 孤狼: 擦。。。。apcupsd会失联 nut在冲到到100的时候会ONBATT进入关机状态,我想想办...
  • 海运: 网络,找到相应的url编辑重发请求,firefox有此功能,其它未知。
  • knetxp: 用浏览器F12网络拦截或监听后编辑重发请求,修改url中的set为set_super,将POS...
  • Albert: 啊啊啊啊啊啊啊啊啊 我太激动了,终于好了英文区搜索了半天,翻遍了 pve 论坛没找到好方法,博...
  • jiangker: good, very helpful to me
  • fengfeng: N1 armbian 能有编译下内核吗。。我要开启can 不懂怎么操作
  • 1: 方法一ngtcp2要改下:./configure PKG_CONFIG_PATH=/usr/l...