海运的博客

n1编译libuv和ipt2socks

发布时间:November 24, 2019 // 分类: // No Comments

ubuntu源安装的libev版本太低,故编译安装最新版libuv:

wget https://github.com/libuv/libuv/archive/v1.33.1.tar.gz
tar zxvf v1.33.1.tar.gz 
cd libuv-1.33.1/
./autogen.sh
./configure --prefix=/usr/local/libuv
make && make install

安装ipt2socks,类似于redsocks,支持ipv6。

git clone https://github.com/zfl9/ipt2socks.git
cd ipt2socks/
make INCLUDES="-I/usr/local/libuv/include" LDFLAGS="-L/usr/local/libuv/lib"
echo '/usr/local/libuv/lib' > /etc/ld.so.conf.d/libuv.conf
ldconfig

使用:

ipt2socks -b 0.0.0.0 -l 7070 -s 127.0.0.1 -p 1080 -R -T

更新:
由于系统自带的libuv大版本和自编译的一样,启动ipt2socks会优先加载系统自带的libuv库,可以在systemd启动脚本中使用LD_LIBRARY_PATH变量指定libuv库位置:

LD_LIBRARY_PATH="/usr/local/libuv/lib/"

标签:none

发表评论

分类
最新文章
最近回复
  • chainofhonor: 感谢,用dnsmasq设置自动判断BIOS和UEFI成功了
  • 海运: 不好意思,这个是很多年前的,现在也许已经不适用,我现在也不用多线了。
  • CQ: -m state --state NEW 替换成-m conntrack --ctstate NEW
  • CQ: 你好,我入站已经成功分流,但是不知道出站怎么设置,PREROUTING替换成POSTROUTI...
  • K: 好的,谢谢,我去试试!
  • 海运: 可以试试3proxy
  • daha: PHP的怎么使用???
  • 海运: 换回了5.3内核,5.8用5.3 dtb虽然能开机且负载正常,但也有其它问题,不建议使用。
  • shangyatsen: 后面的内核高精度计时器的问题使用5.4或者5.3的dtb会正常吗?我也发现有这个日志出现。感觉...
  • 海运: 缺少相应模块?