海运的博客

使用kcptun加速ss连接速度

发布时间:February 23, 2017 // 分类: // No Comments

kcptun是一种双向加速软件,可用于openvz,经测速速度比单向加速软件锐速和bbr好很多。
安装golang并build kcptun:

go get -v -u github.com/xtaci/kcptun/client
go get -v -u github.com/xtaci/kcptun/server
VERSION=`date -u +%Y%m%d`
LDFLAGS="-X main.VERSION=$VERSION -s -w"
GCFLAGS=""
env CGO_ENABLED=0 GOOS=linux GOARCH=amd64 go build -ldflags "$LDFLAGS" -gcflags "$GCFLAGS" -o kcptun_client github.com/xtaci/kcptun/client
env CGO_ENABLED=0 GOOS=linux GOARCH=amd64 go build -ldflags "$LDFLAGS" -gcflags "$GCFLAGS" -o kcptun_server github.com/xtaci/kcptun/server

服务器启动ss和kcptun:

ss-server -m rc4-md5 -p 58888 -k key-t 7200
kcptun_server -l :58999 -t 127.0.0.1:58888 -mtu 1400 -sndwnd 1024 -rcvwnd 256 -mode fast2 -crypt aes-128 -key key

客户端启动ss和kcptun:

kcptun_client -l :7071 -r serverip:58999 -mtu 1400 -sndwnd 256 -rcvwnd 1024 -mode fast2 -dscp 0 -crypt aes-128 -key key
ss-local -s 127.0.0.1 -p 7071 -k key-l 7070 -b 0.0.0.0 -m rc4-md5 -t 86400

PHP下AES CBC/CFB 256加密

发布时间:February 3, 2017 // 分类:PHP // No Comments

AES CFB加解密:

<?php
$iv = substr(md5("iv"),0,16);
$encryption_key = substr(md5("key"),0,32);
echo $encryption_key."\n";
$data = 'data';
$data = openssl_encrypt($data, 'aes-256-cfb', $encryption_key, OPENSSL_RAW_DATA|OPENSSL_ZERO_PADDING, $iv);
echo bin2hex($data) . "\r\n";

$iv = substr(md5("iv"),0,16);
$data = openssl_decrypt($data, 'aes-256-cfb', $encryption_key, OPENSSL_RAW_DATA|OPENSSL_ZERO_PADDING, $iv);
echo $data . "\r\n";
?>

AES CBC加解密:

<?php
$iv = substr(md5("iv"),0,16);
$encryption_key = substr(md5("key"),0,32);
$data = 'data';
$data = openssl_encrypt($data, 'aes-256-cbc', $encryption_key, OPENSSL_RAW_DATA, $iv);
echo bin2hex($data) . "\r\n";

$iv = substr(md5("iv"),0,16);
$data = openssl_decrypt($data, 'aes-256-cbc', $encryption_key, OPENSSL_RAW_DATA, $iv);
echo $data . "\r\n";
?>

易语言调用openssl库实现aes cbc/cfb 256加密

发布时间:February 3, 2017 // 分类: // 1 Comment

AES分块加密,每块16字节,IV大小等于块大小,key大小等于加密强制128/256位。
自定义数据类型:

.版本 2

.数据类型 AES_KEY
    .成员 rd_key, 整数型, , "60"
    .成员 rounds, 整数型

自定义DLL命令:
.版本 2

.DLL命令 AES_set_encrypt_key, 整数型, "libeay32.dll", "@AES_set_encrypt_key", , int AES_set_encrypt_key(const unsigned char *userKey, const int bits, AES_KEY *key);
    .参数 userKey, 文本型, 传址
    .参数 bits, 整数型
    .参数 key, AES_KEY, 传址

.DLL命令 AES_set_decrypt_key, 整数型, "libeay32.dll", "@AES_set_decrypt_key", , int AES_set_decrypt_key(const unsigned char *userKey, const int bits, AES_KEY *key);
    .参数 userKey, 文本型, 传址
    .参数 bits, 整数型
    .参数 key, AES_KEY, 传址

.DLL命令 AES_cbc_encrypt, , "libeay32.dll", "@AES_cbc_encrypt", , void AES_cbc_encrypt(const unsigned char *in, unsigned char *out, size_t length, const AES_KEY *key, unsigned char *ivec, const int enc);
    .参数 in, 字节集
    .参数 out, 字节集
    .参数 length, 整数型
    .参数 key, AES_KEY
    .参数 ivec, 字节集
    .参数 enc, 整数型

.DLL命令 AES_cfb_encrypt, , "libeay32.dll", "@AES_cfb128_encrypt", , void AES_cfb128_encrypt(const unsigned char *in, unsigned char *out, size_t length, const AES_KEY *key, unsigned char *ivec, int *num, const int enc)
    .参数 in, 字节集, 传址
    .参数 out, 字节集, 传址
    .参数 length, 整数型
    .参数 key, AES_KEY, 传址
    .参数 ivec, 字节集, 传址
    .参数 int, 整数型, 传址
    .参数 enc, 整数型

AES CBC加解密,须补码:

.版本 2
.支持库 dp1
.支持库 spec

.子程序 AES_CBC
.局部变量 key, AES_KEY
.局部变量 output, 字节集
.局部变量 iv, 字节集
.局部变量 len, 整数型
.局部变量 source, 字节集
.局部变量 key_str, 文本型

.版本 2
.支持库 dp1
.支持库 spec
'iv 16字节
iv = 到字节集 (取文本左边 (取数据摘要 (到字节集 (“iv”)), 16))
source = 到字节集 (“data”)
'加密强度256位,密钥取32字节
key_str = 取文本左边 (取数据摘要 (到字节集 (“key”)), 32)
.如果真 (AES_set_encrypt_key (key_str, 256, key) < 0)
    返回 ()
.如果真结束
'补码
len = 取字节集长度 (source)
.计次循环首 (16 - len % 16, )
    source = source + { 0 }
.计次循环尾 ()
调试输出 (source)
len = 取字节集长度 (source)
output = 取空白字节集 (len)
AES_cbc_encrypt (source, output, len, key, iv, 1)
调试输出 (“en”, output)

.如果真 (AES_set_decrypt_key (key_str, 256, key) < 0)
    返回 ()
.如果真结束
iv = 到字节集 (取文本左边 (取数据摘要 (到字节集 (“iv”)), 16))
source = output
output = 取空白字节集 (len)
AES_cbc_encrypt (source, output, len, key, iv, 0)
调试输出 (“de”, output)
调试输出 (到文本 (output))

AES CFB加解密,无须补码,加密数据等于原始数据大小:

.版本 2
.支持库 dp1
.支持库 spec

.子程序 AES_CFB
.局部变量 key, AES_KEY
.局部变量 output, 字节集
.局部变量 iv, 字节集
.局部变量 len, 整数型
.局部变量 source, 字节集
.局部变量 key_str, 文本型
.局部变量 n, 整数型

iv = 到字节集 (取文本左边 (取数据摘要 (到字节集 (“iv”)), 16))
source = 到字节集 (到字节集 (“data”))
key_str = 取文本左边 (取数据摘要 (到字节集 (“key”)), 32)
.如果真 (AES_set_encrypt_key (key_str, 256, key) < 0)
    返回 ()
.如果真结束
len = 取字节集长度 (source)
output = 取空白字节集 (len)
AES_cfb_encrypt (source, output, len, key, iv, n, 1)
调试输出 (“en”, output)

'cfb下设解密key也用AES_set_encrypt_key
.如果真 (AES_set_encrypt_key (key_str, 256, key) < 0)
    返回 ()
.如果真结束
iv = 到字节集 (取文本左边 (取数据摘要 (到字节集 (“iv”)), 16))
source = output
output = 取空白字节集 (len)
n = 0
AES_cfb_encrypt (source, output, len, key, iv, n, 0)
调试输出 (output)
调试输出 (“de”, 到文本 (output))

PHP版AES CBC/CFB加解密,与易语言版兼容。

Procmon监控程序行为使用技巧

发布时间:January 31, 2017 // 分类: // No Comments

快速定位要监控的程序及其子程序,打开process tree选择相应的进程并点击include subtree:
2017-01-31_151342.png
使用file summary/registry summary查看文件/注册表读写操作统计:
2017-01-31_150629.png
enable advanced output详细的查看对文件所进行的操作,点击右上角的图标快速过滤包含文件/注册表/网络操作。
另外火绒剑及total uninstall的安装程序快照也不错。

Linux删除文件空间未释放

发布时间:December 24, 2016 // 分类: // No Comments

查看哪个进程在使用删除的文件,然后重启相应的进程即可。

lsof |grep deleted
分类
最新文章
最近回复
  • ccc: 可以提供易调用openssl常用函数吗?
  • 夜未央: 在centos7 下面 貌似转换不了。有人遇到过么????
  • brian: 博主你好,请教一个问题。我使用fprobe进行将交换机流量转换成netflow时是没有问题的,...
  • 吴昊: 学习了,感谢博主分享
  • linhua: 只需配置 服务端 的接收端口随机化就行了, 发送端口 因为 连接追踪(conntrack)的缘...
  • Realm: 博主你好,按照你的教程设置了IP转发及SNAT:echo 1 > /proc/sys/net/...
  • Roki: 大神, 为什么我在make clean 就出错了呢 ?你能帮我看看吗 。。。474495758...
  • Duuge: 遇到相同的问题,但未能解决,请求帮助。1、遇到的问题:/target-i386_i486_uC...
  • carlo: 大哥,我觉得你的技术好牛逼!能加你QQ吗
  • lebron: Unknown package 'lrzsz'.Collected errors:* opkg...
归档
友情链接
页面执行耗时:0.0446秒。-->