海运的博客

潘多拉/OpenWRT配置无线wifi访客网络

发布时间:March 18, 2019 // 分类:K2P // No Comments

配置一个无线接口,device名称见同配置文件:

config wifi-iface 'guest'
        option device 'ra'
        option mode 'ap'
        option ssid 'PandoraBox-2.4G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

给创建的无线接口配置静态IP:

config interface 'guest'
       option proto 'static'
       option ipaddr '10.0.0.1'
       option netmask '255.255.255.0'

配置dhcp:

config dnsmasq
        #监听所有网卡
        option nonwildcard '0'
        #监听特定网卡
        #option nonwildcard '1'
        #list interface 'lan'    
        #list interface 'guest'  
        #略过

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '1h'

配置iptables防火墙,访客网络接口为ra1:

iptables -A INPUT -i ra1 -p udp -m multiport --dport 53,67:68 -j ACCEPT
iptables -A FORWARD -i ra1 -o pppoe-wan -j ACCEPT

同时开放5G和2.4G访客网络:

config wifi-iface 'guest'
        option device 'ra'
        option mode 'ap'
        option ssid 'PandoraBox-2.4G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

config wifi-iface 'guest5'
        option device 'rax'
        option mode 'ap'
        option ssid 'PandoraBox-5G-Guest'
        option network 'guest'
        option rssikick '0'
        option rssiassoc '0'
        option encryption 'psk2'
        option key 'password'
        option isolate '1'

将2.4G和5G桥接:

config interface 'guest'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'ra1 rax1'
        option _orig_bridge 'true'
        option ifname 'rax1'
iptables -A INPUT -i br-guest -p udp -m multiport --dport 53,67:68 -j ACCEPT
iptables -A FORWARD -i br-guest -o pppoe-wan -j ACCEPT

更改guest无线密码:

#!/bin/sh
str=haiyun`date +%s|cut -c 7-10|sed 's/4/6/g'`
echo $str
uci set wireless.guest.key=$str
uci set wireless.guest5.key=$str
uci commit wireless
wifi reload

参考:
https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guest-wlan

Windows10桌面快捷不显示图标

发布时间:March 11, 2019 // 分类: // No Comments

使用以下脚本删除图标缓存:

@echo off
taskkill /im explorer.exe /f
cd /d %userprofile%\appdata\local
del iconcache.db /a 
start explorer

linux/windows禁用ipv6隐私临时地址

发布时间:March 6, 2019 // 分类: // No Comments

linux下修改sysctl.conf:

net.ipv6.conf.all.use_tempaddr=0
net.ipv6.conf.eth0.use_tempaddr=0 
net.ipv6.conf.default.use_tempaddr=0 

windows下执行命令:

netsh interface ipv6 set privacy state=disable

N1盒子备份armbian/linux/ubuntu系统到img镜像

发布时间:March 2, 2019 // 分类:N1 // No Comments

新建个2G的img文件:

fallocate -l $(( 2048 * 1024 *1024 )) ubuntu.img

挂载img为loop设备:

losetup -f -P -show ubuntu.img 

分区:

 cat > fdisk.cmd <<-EOF
o
n
p
1

+128MB
t
c
n
p
2


w
EOF
fdisk ubuntu.img < fdisk.cmd 

格式化及挂载:

mkfs.vfat -n "BOOTFS" /dev/loop0p1 
mke2fs -F -q -t ext4 -L ROOTFS -m 0 /dev/loop0p2
mkdir /img
mount /dev/loop0p2 /img
mkdir /img/boot
mount /dev/loop0p1 /img/boot

备份系统:

cd /
DIR_INSTALL=/img
cp -r /boot/* /img/boot/
mkdir -p $DIR_INSTALL/dev
mkdir -p $DIR_INSTALL/media
mkdir -p $DIR_INSTALL/mnt
mkdir -p $DIR_INSTALL/proc
mkdir -p $DIR_INSTALL/run
mkdir -p $DIR_INSTALL/sys
mkdir -p $DIR_INSTALL/tmp

tar -cf - bin | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - boot | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - etc | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - home | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - lib | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - opt | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - root | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - sbin | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - selinux | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - srv | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - usr | (cd $DIR_INSTALL; tar -xpf -)
tar -cf - var | (cd $DIR_INSTALL; tar -xpf -)
sync

用作U盘启动,boot/uEnv.ini文件:

bootargs=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0

etc/fstab文件:

LABEL=ROOTFS / ext4 defaults,noatime,nodiratime,commit=600,errors=remount-ro 0 1
LABEL=BOOTFS /boot vfat defaults 0 2
tmpfs /tmp tmpfs defaults,nosuid 0 0
分类
最新文章
最近回复
  • 海运: 正常情况下编译整个内核执行make menuconfig后就不会出现此提示,当单独编译单个模块...
  • oijq: 就是用的armbian的配置文件哈,按你的教程做的,在执行make LOCALVERSION=...
  • 海运: 使用armbian的配置文件,其它添加或修改自己懂的部分,不懂的就不要碰了。
  • oijq: 编译时这些选项全部选Y吗?Actions Semi Platforms (ARCH_ACTIO...
  • 海运: n1编译bbr内核模块参考这个:https://www.haiyun.me/archives/...
  • jiqz: make M=net/ipv4/ CONFIG_TCP_CONG_BBR=m modules编...
  • ruralhunter: 哦,文档里应该是对的,是.config
  • ruralhunter: cp /mnt/boot/config-4.18.7-aml-s9xxx .config这里应...
  • 海运: 你是编译不成功呢?还是编译后不能运行呢?还是运行后不能访问web界面呢?
  • 白墨: 可能不清楚就是编译安装后启动后访问不了web界面
归档